Upgrading ArcGIS Python

     Python 2.6 and ArcGIS 9.3

    • Install python 2.6, and the latest corresponding pywin32.
    • Grab the arcgisscripting.py script written by Philippe Le Grand (taken from this thread in the ESRI scripting forum) and plop it into
      C:\Python2.6\Lib\site-packages
    • Make sure PYTHONPATH environment variable points to C:\path\to\ArcGIS\bin
    • Note: this is an unsupported configuration, see ESRI:31912

    The same recipe works for python 2.5 and arcgis 9.2, just change the numbers accordingly.

    How To use a version of python newer than 2.1 with ArcGIS 9.1

    • Uninstall v2.1, including win32all extensions
    • Install the python version you want
    • Install the matching win32all extensions
    • Create a text file called py-win32all.reg containing the text below (change 204 to match the win32all build number) and double click on it.

     

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Python\Pythonwin]
    [HKEY_LOCAL_MACHINE\SOFTWARE\Python\Pythonwin\Build]
    @="204"

    Adapted from: ESRI:26872

        Send feedback